Phoronix Test Suite

An Automated, Open-Source Testing Framework

Latest Release: Phoronix Test Suite 5.0.1

Home Downloads Features Documentation Contact OpenBenchmarking.org Forum Support

Download

The only explicit requirement for the Phoronix Test Suite on Linux, OpenSolaris, *BSD, Windows 7, and Mac OS X operating systems is PHP5 CLI (packages for it are usually called php5-cli or php-cli or just php). Note that only PHP5 is needed and not a web server or other packages commonly associated with PHP. Many of the benchmarking profiles do require the standard Linux development tools/libraries (GCC, etc) and other common programs. However, on many Linux distributions and operating systems the Phoronix Test Suite is able to use the software's package management system for installing these additional dependencies. On a clean Ubuntu installation, it's as easy as first running sudo apt-get install php5-cli and then setting up the Phoronix Test Suite.

The detailed installation instructions can be found in the online documentation.

It is recommended all users use the latest release available. The git repository for the latest development code can be obtained using git-clone https://github.com/phoronix-test-suite/phoronix-test-suite.git. The Phoronix Test Suite is hosted on GitHub.

The release history page offers details on past Phoronix Test Suite releases.

Phoronix Test Suite 5.0 (Official)

Latest Release: 5.0.1-Plavsk (02 April 2014)

Download Phoronix Test Suite - Generic Package SHA1: 2dbaacd681a52941130761a5a0a2427653f119ad

Download Phoronix Test Suite - Debian/Ubuntu Package